Page 1 of 1

Can't open config file

Posted: Thu Feb 19, 2009 4:09 pm
by masrawy

I got the Z88DK compiler on my Linux PC. I am trying to compile a simple program for a TI-86 calculator. It's located in a file called "main.c". I typed:

$ zcc +ti86 main.c

and I got:

Can't open config file /usr/lib/z88dk/lib/config/ti86.cfg

Sorry if this is sort of an obvious problem. Anyway, I checked in the directory mentioned above, and it looks like I don't even have a folder called 'z88dk' in /usr/lib.

Thanks for the help.


Posted: Thu Feb 19, 2009 8:23 pm
by stefano
Are you using the source version or a package from some distribution ? Which distro ?

Posted: Thu Feb 19, 2009 9:27 pm
by masrawy
stefano: I downloaded the source, compiled it, and got that result. Then (since I'm using Ubuntu) I typed:

$ sudo apt-get install z88dk-bin

tried again, and got the same exact output.

Posted: Thu Feb 19, 2009 10:15 pm
by dom
It looks like there are several packages on ubuntu, I'm guessing apt-get install z88dk will add in the other required packages (z88dk-data being the one that's missing I'm guessing).

Regarding compiling from source - did you do a make install? If you didn't then you'd get a similar error unless you set the ZCCCFG environment variable.

[I've moved the topic into the Other Platforms section where it's more appropriate]

Posted: Tue Apr 20, 2010 9:03 pm
by winston
Just for reference I get the same error after installing on OS X (Snow leopard) with the nightly build from source. I have done a make install (I've followed the build steps in README.1st).