Page 1 of 1

Installation problem/Linux Ubuntu Gutsy

Posted: Fri Nov 28, 2008 11:49 am
by jp44

I've tried to install z88dk to my Ubuntu, have made both HOME and system root installations, tried also two versions (1.7, 1.8),
have defined both Z80_OZFILES and ZCCFG and PATH variables but I'm still getting this error message when trying to compile

zcc +zx synthdemo.c
cp /wd/emu/z88dk/lib/spec_crt0.opt /tmp/tmpXXo4Ye2a.opt
cp /tmp/tmpXXo4Ye2a.opt /tmp/tmpXXo4Ye2a.asm
zcpp -I. -DZ80 -DSMALL_C -DSPECTRUM -D__SPECTRUM__ -DSCCZ80 -I/wd/emu/z88dk/include synthdemo.c /tmp/tmpXXDRzdIc.i
sccz80 -// /tmp/tmpXXDRzdIc.i
copt /wd/emu/z88dk/lib/z80rules.2 < /tmp/tmpXXDRzdIc.asm > /tmp/tmpXXDRzdIc.op1
copt /wd/emu/z88dk/lib/z80rules.1 < /tmp/tmpXXDRzdIc.op1 > /tmp/tmpXXDRzdIc.opt
z80asm -eopt -ns -Mo /tmp/tmpXXDRzdIc.opt
z80asm -a -m -Mo -oa.bin -i/wd/emu/z88dk/lib/clibs/zx_clib -i/wd/emu/z88dk/lib/clibs/z80_crt0 /tmp/tmpXXo4Ye2a.opt /tmp/tmpXXDRzdIc.o
2 errors occurred during assembly
Key to filenames:
/tmp/tmpXXDRzdIc.o = synthdemo.c
File '/wd/emu/z88dk/lib/clibs/zx_clib.lib', Module 'FCLOSE', Symbol not defined
Error in expression CLOSE

File '/wd/emu/z88dk/lib/clibs/zx_clib.lib', Module 'FPUTC', Symbol not defined
Error in expression WRITEBYTE

Any advices ?

Best and thanks, Jukka

Posted: Fri Nov 28, 2008 12:08 pm
by stefano
You simply miss to include the I/O library.
Since z88dk is able to support several mass storage device it is possible to bind your favourite Spectrum expansion libraries (i.e. the microdrives).
The synthdemo module doesn't need disk I/O, so you can use the "ndos" foo stub:

zcc +zx -lndos synthdemo.c

For detailed information on the fcntl drivers, you can have a look here: ... trum:fcntl

Posted: Fri Nov 28, 2008 1:35 pm
by jp44
Thanks, works now, I thougt it was something simple, tried other libraries but not this.


Posted: Mon Dec 01, 2008 2:34 pm
by stefano
Fine. Have also a look at the other ZX Spectrum related pages:

See also point 5 in the main wiki menu.