zcc.exe not working correctly after install

Installing on windows
Post Reply
na_th_an
New member
Posts: 4
Joined: Thu Jul 19, 2007 10:30 am

zcc.exe not working correctly after install

Post by na_th_an »

I downloaded 1.7, it comes a a zipped z88dk folder. No installer (although the INSTALL.TXT tells me to use it :P).

My problem comes executing zcc.exe to compile. It claims that "cp is not a valid command". AFAIK, cp is for linux. Shouldn't this be calling "copy"? What am I missing? Do I need to install a shell or something? I hope not.

Cheers :)
User avatar
dom
Well known member
Posts: 1194
Joined: Sun Jul 15, 2007 10:01 pm

Post by dom »

You'll need to change the COPYCMD line in the config file z88dk/lib/config/*.cfg so that it reads copy not cp.

Installer is forthcoming...as is z88dk 1.7.1 :)
na_th_an
New member
Posts: 4
Joined: Thu Jul 19, 2007 10:30 am

Post by na_th_an »

Thanks for your prompt answer :)
Now let's get busy.

Greetings!
siggi
Well known member
Posts: 343
Joined: Thu Jul 26, 2007 9:06 am

Post by siggi »

I copied the whole compiler directories from a XP machine to a WIN98SE machine and set there the environment variables and path. When I try to compile a program, that can be compiled at with the XP machine, I get an assembly error, because the assembler does not find the include file in main:
INCLUDE "#z80_crt0.hdr"

The real file name is only "z80_crt0.hdr". So who should throw away the '#" to access the real file? Is it an environment problem?

Siggi
User avatar
dom
Well known member
Posts: 1194
Joined: Sun Jul 15, 2007 10:01 pm

Post by dom »

I think you're missing the setting for Z80_OZFILES which needs to point to the {z88dk}/lib directory.
siggi
Well known member
Posts: 343
Joined: Thu Jul 26, 2007 9:06 am

Post by siggi »

My environment seems to be okay:

TMP=C:\WINDOWS\TEMP
TEMP=C:\WINDOWS\TEMP
PROMPT=$p$g
winbootdir=C:\WINDOWS
COMSPEC=C:\WINDOWS\COMMAND.COM
PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;C:\BITWARE\;C:\Z88DK\BIN\
Z80_OZFILES = C:\Z88DK\LIB\
ZCCCFG = C:\Z88DK\LIB\CONFIG\
windir=C:\WINDOWS

Might there be a problem with filenames in UPPER/lower case letters?

Siggi

Addendum: I tried also the path name without trailing \:
Z80_OZFILES = C:\Z88DK\LIB
ZCCCFG = C:\Z88DK\LIB\CONFIG

Same result.
Last edited by siggi on Wed Aug 15, 2007 7:12 pm, edited 1 time in total.
siggi
Well known member
Posts: 343
Joined: Thu Jul 26, 2007 9:06 am

Post by siggi »

Heureka!
now it works!

I found in the Z88DK directories an Inf-File for WIN95, which works also on my WIN98SE.
It set the environvent to that:

Z80_OZFILES=C:\z88dk\Lib\
ZCCCFG=C:\z88dk\Lib\Config\
PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;C:\BITWARE\;C:\Z88DK\BIN

That mixture of Uppercase/lOWERCASE directory names seems to make the assembler happy :-))

Siggi
Post Reply