ti 84+ problem

TI-82, TI-83 (plus, silver..), TI-84, TI-85 and TI-86
Post Reply
deforme
New member
Posts: 3
Joined: Thu Feb 23, 2012 3:36 am

ti 84+ problem

Post by deforme »

i tried some variation when i was compiling code.
i used :
zcc +ti8x -startup=10 a.c -o main2.bin
>zcc +ti83 a.c -o main2.bin
zcc +ti8x -o adv_a -create-app a.c
zcc +ti83 -o adv_a -create-app a.c
zcc +ti83ansi -lm -o adv_a -create-app a.c
zcc +ti8xansi -lm -o adv_a -create-app a.c
appmake.exe +ti8x -b main2.bin
appmake.exe +ti8x -b main2.bin

and i got always err:sytax when i tried asm(xxxx i got err:data type

source i tried


#pragma string name HELLO

#include "stdio.h"

int main() {
printf("hehe");
return 0;
}

thanks for replies
deforme
New member
Posts: 3
Joined: Thu Feb 23, 2012 3:36 am

Post by deforme »

i solved i used wron command but now system closing when i load program with asm then i open it says ram cleared 2.43

zcc +ti8xansi -lm -startup=10 -o hello a.c
appmake.exe +ti8x -b hello

i used this ...
thanks for replies
stefano
Well known member
Posts: 1534
Joined: Mon Jul 16, 2007 7:39 pm

Post by stefano »

Reading in this forum I see the following suggestion; try substituting appmake with 'bin2var':
bin2var hello hello.8xp
contra-sh
Member
Posts: 13
Joined: Mon Feb 28, 2011 9:23 am

Post by contra-sh »

Stefano is right, it's seems there's some issue with appmake. I've tried to use it but I never got a valid output file.

Here a solution for you problem :

The code (hello.c) :
#include <stdio.h>

main() {

printf("hello world\n\n\n\n");
while (1) {
// ne finit jamais
}


}
The Makefile :
all:
zcc +ti8xansi -lm -startup=10 -o hello hello.c
bin2var hello OUTPUT.8xp

clean:
rm *.83p
And the result :

Image

Some technical stuff...
bin2var do the packaging stuff (add and header and a footer) to the file.
The header is composed by a magic number, the name (which could be different from filename), a comment, a checksum (footer) and some other stuff...
http://www.ticalc.org/cgi-bin/zipview?t ... 83_83+.txt

How to find bin2var ?
Here : http://www.ticalc.org/archives/files/fi ... 14394.html
(You need to compile it because the binary is for windows)


If I use appmake instead of bin2var I have an error...

Now let's study the two generated files.
I see 1 big mistake, maybe checksum is not valid but as the files are different I can't say without calculating it.
The main problem, the length data part (0x44 and 0x45) are equal to 00 00 !!!
And in fact, this padding shift the entire file.
There's probably some other problems I don't know.

This is quite strange because it seems that appmake simply uses bin2var to convert the files...

I will look further inside the z88dk code to see what's wrong.

Good luck for your C projects deforme. What are you expecting to do?
Post Reply