[genccon] [ADAM] scrolling broken in 9918 text mode

Post Reply
tschak909
Member
Posts: 111
Joined: Sun Sep 09, 2018 5:44 pm

[genccon] [ADAM] scrolling broken in 9918 text mode

Post by tschak909 »

When using the generic console, scrolling is broken outright, the second to bottom line keeps being repeated, while the text on the last line is changedd.

Test program:

Code: Select all

#include <conio.h>
#include <msx.h>

void main(void)
{
     int i=0;
     while(1) { printf("%d",i++); }
}
User avatar
dom
Well known member
Posts: 1506
Joined: Sun Jul 15, 2007 10:01 pm

Re: [genccon] [ADAM] scrolling broken in 9918 text mode

Post by dom »

Sorry Thom I’ve not had a chance to look at this yet.

I’m guessing this is mode 2? It’s odd that code hasn’t changed in years and I thought it was working.
tschak909
Member
Posts: 111
Joined: Sun Sep 09, 2018 5:44 pm

Re: [genccon] [ADAM] scrolling broken in 9918 text mode

Post by tschak909 »

oop sorry, that's mode 0.

there's supposed to be an msx_set_mode(0); in there. :)
User avatar
dom
Well known member
Posts: 1506
Joined: Sun Jul 15, 2007 10:01 pm

Re: [genccon] [ADAM] scrolling broken in 9918 text mode

Post by dom »

That makes more sense...there were a couple of bugs there....

Should be fixed in the next nightly - thanks for the report!
tschak909
Member
Posts: 111
Joined: Sun Sep 09, 2018 5:44 pm

Re: [genccon] [ADAM] scrolling broken in 9918 text mode

Post by tschak909 »

Yup, definitely fixed.
WIN_20211122_14_27_56_Pro.jpg
(don't mind missing chars, adamnet timing is still not 100% correct)

-Thom
You do not have the required permissions to view the files attached to this post.
Post Reply